Welcome, Guest

TOPIC: Omnistep 550

Omnistep 550 4 weeks 1 day ago #8908

  • randonneur
  • randonneur's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 13
  • Thank you received: 6
We have an Auto-Trail 2007 Tracker and are having problems with the 12v Omnistep. We think its the motor but can't get the step out to dismantle it to get at the motor. At one point the step was coming in and out of its own accord but now it is permanently in. I have spoken to Auto-Trail and they say that it must be connected to the 12v which it already is so they were no help at all.
The administrator has disabled public write access.

Omnistep 550 3 weeks 6 days ago #8911

  • TonyJones
  • TonyJones's Avatar
  • Offline
  • Moderator
  • Husband, father, retired minister, MOTORHOMER!
  • Posts: 1494
  • Thank you received: 159
Ours often used to get jammed with road grunge and needed a good clean, but the earlier symptoms on yours suggest more to it than that.
Ours had some external bolts, and support brackets underneath, which were all accessible whether the step was in or out. If yours aren't, you probably need a professional to dismantle it. Shouldn't be too expensive though, I'd have thought.
Voluntary Moderator (but all opinions are my own!)
2005 Bürstner Privilège Citroen
"If God had intended us to fly, He wouldn't have given us motorhomes!"
The administrator has disabled public write access.

Omnistep 550 3 weeks 3 days ago #8916

  • randonneur
  • randonneur's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 13
  • Thank you received: 6
Thanks Tony. Since my post I have managed to get the platform of the step off, it started going in and out of its own accord so thought it better to remove the fuse so that it didn't flatten the battery. I have taken the fuse out before and replaced it as I thought that might be the problem, anyway took the fuse out and then put it back, it beeped and has been working perfectly ever since. Before I put the step platform back I liberally doused the motor in WD40 just to be on the safe side. I can confirm that 2 days later it is still working fine with the key fob and the switch just inside the door. Electrics are a law unto themselves.

I did find some PDFs on the Thule website regarding these steps and they are very informative.
The administrator has disabled public write access.

Omnistep 550 3 weeks 2 days ago #8919

  • TonyJones
  • TonyJones's Avatar
  • Offline
  • Moderator
  • Husband, father, retired minister, MOTORHOMER!
  • Posts: 1494
  • Thank you received: 159
Glad you got it sorted!
Voluntary Moderator (but all opinions are my own!)
2005 Bürstner Privilège Citroen
"If God had intended us to fly, He wouldn't have given us motorhomes!"
The administrator has disabled public write access.

Most recent motorhome reviews